Dropped Packets when switching from 2.4 Ghz - 5 Ghz & Vice Versus

Comes here often

Dropped Packets when switching from 2.4 Ghz - 5 Ghz & Vice Versus

I am in the process of setting up a new site. I have a number of MR52's covering the indoors and have MR74 covering an outdoor area. I get good signal in 2.4 Ghz around the whole area. As I am moving around testing on the MR74 when my device switches to 5 Ghz I drop packets and vice versus. I managed to replicate this on an MR52. This happens on both android and apple devices.
The way I see it there are a number of options I can try. I could increase the minimum bitrate on the 5 Ghz Channel so it only switches when the signal reaches above a certain level.

I could disable 5Ghz on the outdoor radios to alleviate this issue but would like to get suggestions before I do something so drastic.


Getting noticed

Loosing a few packets when switching radios is normal, the renegotiation time is a factor. 

Kind of a big deal

You can roam within the same frequency band.  I'm not sure about roaming between 2.4Ghz and 5Ghz.


I'm pretty sure things like 802.11r only report other APs in the same band for roaming assistance.


This will depend a lot on how good the driver is. 

This is what I suspected that roaming withing the same band is seamless and switching radios will cause packets to drop. May go the route of disabling 5 Ghz on radios where devices will be roaming.

Kind of a big deal

Is 5GHz not providing the coverage you need? You'd be much better off disabling 2.4GHz if you're going to disable something. Since you're deploying MR52's I imagine you're looking for quite high client throughput and density, which is not what you're going to get with a 2.4-only deployment. 

Comes here often

My Thought at this point is to change the RF profile for the outdoor access points where there will be less devices connected to exclude 5 Ghz. leaving the indoor units with both 5 Ghz and 2.4 Ghz where there will be larger number of devices connected.this will hopefully give me the best of both worlds.

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.