Do MR APs block multicast within the same vlan?

ChrisLaird
Here to help

Do MR APs block multicast within the same vlan?

I think I might be misunderstanding something about how Meraki handles multicast. We have 4 scenarios, but only 3 work.

 

1. broken - two laptops in a client/server pair. the client says "_simlink._tcp.local" queries looking for its server, the server is constantly broadcasting its address. When the two are wired on vlan 10, it works perfectly. When the two are connected wirelessly through an MR42 to vlan 10, the traffic can't make it through, according to Wireshark. It looks like some apple bonjour traffic from other devices on vlan 10 is making it through, but not the traffic we're looking for

 

2. working - apple devices using the bonjour gateway. easy peasy, just not relevant above since we're not sending traffic to a different network.

 

3. working - video encoders and decoders using the IGMP querier settings in meraki, all within same vlan

 

4. working - video encoders and decoders using the PIM sparse mode through a nexus switch, to traverse vlans.

 

We're trying to figure out how to get the first scenario working, where we don't need to traverse vlan, it's not apple's bonjour, and as far as I'm aware, we don't need IGMP. Thanks in advance.

10 REPLIES 10
ww
Kind of a big deal
Kind of a big deal

Only setting regarding multicast i know is in network > general

"Wireless Multicast to Unicast Conversion"

On the ssid L2 lan isolation is disabled? and no L3 fw blocking anything?

I'm not sure if the multicast to unicast conversion is doing it. Our network is around ~1,100 APs and we're only testing on 1-2 APs, so turning off that setting seems like a mighty big hammer for such a small nail.

 

I've checked but am not seeing any firewalls in the way. I've made sure they're turned off for this. Client isolation is not enabled. 

ww
Kind of a big deal
Kind of a big deal

You can always move 2 ap's to a new  network and do some testing

PhilipDAth
Kind of a big deal

Are you trying to run the multicast generator from a WiFi device?  I would not expect that to work.

 

If it is just a client - that should be fine.

It's just 2 windows laptops connected to wireless, each running the vendor's software. The software works perfectly when the two laptops are wired, but the multicast goes missing when both laptops are wireless. We didn't expect this to be the case, since both wired and wireless devices are all configured to use the same vlan 10.

What is generating the multicast stream?

It's a configuration test software from Laerdal medical. We're in the process of making changes to the way their devices communicate, so we're running the configuration verification tool and it's failing on the network pieces. We have their configuration guide for normal Cisco controllers, which walks through adding custom mdns strings and modifying settings, but there's nothing for Meraki.

jmoake
Getting noticed

Are the laptops on the same AP and same SSID?  I would expect that if they are, they will not talk to each other because I think the APs do not directly let devices see each other locally.  if one laptop was on a different SSID, or if they were on different APs, they might work.  

It doesn't work in either situation. Although, I'm not aware of APs blocking traffic like that unless client isolation is enabled. Which, in this case, it is not.

Hello,

 

Was this ever resolved?  I'm having the same issue using Laerdal's Network Validator Tool.

 

Thanks.

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.