cancel
Showing results for 
Search instead for 
Did you mean: 

Devices not switching APs quickly

Here to help

Devices not switching APs quickly

We have a mixed environment of windows and apple laptops as well as ios and android mobile devices. I've done a lot of tweaking to our system since joining the company but, I feel like devices are still staying attached to APs and not changing quickly enough to new APs when they roam or not changing at all.

 

We use MR42 APs and we have 9 in the building right now. The building is a 3 story, concrete nightmare. Mostly concrete walls with glass conference room walls. It's your typical rectangular shaped but, internally there are just a lot of obstructions. 3 APs per floor, evenly spread out, linearly (or as near to linear as possible... not my choice but it was handed to me like that and I just have to deal with that layout for now).

 

Things I've done to improve the wlan:

  • Change 5GHz to 40Mhz wide instead of 80Mhz (we don't have a super fast ISP connection and I don't really find it necessary to be on 80MHz wide channels).
  • Set transmit power of 2.4GHz range to 14dBm and 5GHz range to 20dBm
  • Manually set 2.4GHz channels to 1,6,11 and map them out so they have as little overlap as possible
  • Manually set 5GHz channels to 36,44,149,157 and also tried to have as little overlap as possible
  • We're near the SJC airport so, I've opted to not use DFS channels
  • I tried enabling 802.11r (yes, we're all patched to avoid the KRACK) but, it seemed to make things especially bad for ios devices so I turned it off

 

After those changes, things seem to be quite a bit better but, I'm always looking to make improvements even if they're just minor. Is there anything anyone here could recommend for improvements or things to look at? I can also post other info (graphs etc) if it's felt that would be helpful. Thank you all for your help!

 

4 REPLIES 4
ww
Head in the Cloud

Re: Devices not switching APs quickly

update your clients driver and tweak the driver (roaming) settings.

set minimum bitrate higher in the dashboard

 

 

Here to help

Re: Devices not switching APs quickly

Yeh I have tweaked the driver settings on the windows clients. Checked our minimum bitrate and it's set to 12Mbps. That seems okay?

Kind of a big deal

Re: Devices not switching APs quickly

If you want clients to roam faster then increase the minimum connect speed to 12Mb/s rather than changing the power level.

Kind of a big deal

Re: Devices not switching APs quickly

Do you have client balancing enabled? You don't have a lot of AP's, so they may be rejecting associations to maintain even load among the three per floor. 

 

Also, have you updated the drivers on Windows clients? I would not recommend changing the driver settings but make sure you are running the latest drivers from the WiFi adapter OEM if at all possible. 

MRCUR | CMNO #12
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.