Clients Disconnecting after 40 minutes from Mr-56 and then will slowly reconnect

Here to help

Clients Disconnecting after 40 minutes from Mr-56 and then will slowly reconnect

I have a classroom with a Mr-56 AP that is dropping all clients (about 30) after 20 to40 minutes or so.

All those clients will then attach themselves to  an Mr-42 in the class next door so it is now serving around 55 clients 

which slows down those clients.

If I don't do anything the clients will start to come back to MR-56 slowly. If I reboot the Mr-56 they connect right away.


Steps that I have tried


I have swapped out the Mr-56 same issue.

Swapped ports, swapped patch cables  same issue

Ran a new Cable to a different switch same issue.


Any comments or ideas would be gladly accepted


Next Step is to put a different model AP in that room.

Here to help

It’s not something like a dhcp lease expiring?

Any of 802.11r or k enabled on the ssid?

Dfs event?

Channels/power aren’t changing?

Kind of a big deal
Kind of a big deal

@AugieV a few more details please:


  1. what firmware are you running
  2. how is the SSID configured: bridged, L3 routing or Meraki DHCP
  3. how are the devices authenticating: PSK, 802.1x etc.
  4. Are there any alerts in the AP log to suggest interference or channel changing from DFS etc?
Here to help



1. Firmware 27.6


2. It is not SSID Specific we actually use all 3


3. PSK authentication


4. Nothing that would suggest interference. I do get a lot of 802.11 disassociation unknown reason even though the client has not moved.

Thanks, Bgammon


No its not a dhcp issue

I do not have 802.11r or K enabled also its not SSID dependant

I don't think its a dfs event I have 134 AP's and I have not seen any dfs events and I have set it on auto-select and it does not change channels very often.

Kind of a big deal

To test whether this is a malicious student if you swap the MR42 and MR56 - does the issue stay in the same classroom (student issue) or follow the MR56 (MR56 issue, possibly firmware)?

Hi Phillip


I will be swapping the Mr-56 for an Mr-42 this afternoon lets see what happens

Here to help

Switching the Mr-56 for an Mr-42 did the trick its been working without an issue for 3 days.

Any Ideas

Kind of a big deal
Kind of a big deal

Clients don't like WiFi 6?


What chipsets are in the client devices, some work better than others when connecting to WiFi 6 APs.

Here to help

We use Apple IPads 6th and 7th Generation but it does not discriminate it just will drop all 30 connections at once and move to the nearest AP. If I see an Mr-56 with 0 clients and I reboot the AP it will reconnect all the clients, Otherwise, it will start to slowly reconnect the Clients. 


It is not client or SSID specific but they are mostly apple products Macbooks, Ipads, Apple Tv's.

Kind of a big deal

I recently just had a customer with an issue with MR56's - and it turned out to be the power saving settings on the NIC on the notebooks.  You want to configure the client NIC to run always at "Maximum performance".


You can automate this change on Windows 10 by running these two commands (while connected to WiFi):

powercfg /SETDCVALUEINDEX SCHEME_CURRENT 19cbb8fa-5279-450e-9fac-8a3d5fedd0c1 12bbebe6-58d6-4636-95bb-3217ef867c1a 0
powercfg /SETACVALUEINDEX SCHEME_CURRENT 19cbb8fa-5279-450e-9fac-8a3d5fedd0c1 12bbebe6-58d6-4636-95bb-3217ef867c1a 0


Not sure if I can do that to apple IPads but I will look in our MDM.



This article may help it is a little old but does contain some of the Apple ecosystems roaming decisions.  What are the minimum data rates set for your aps?  You don’t have differing radio profiles for the different aps?


There is also some tools that Apple offer to run some capturing from the devices.  There logs are pretty verbose but may help to capture what is prompting them to dissaccoiate.


found this on the ubiquiti forums as well, although old does seem to point to fast roaming.

Rather than disabling the 802.11r and k/v settings try enabling them. I believe there is an adaptive mode as well. 









Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.