Amazon Echo Multi-room Music

Meraki Employee

Amazon Echo Multi-room Music

All of my Echo's are connected and I am able to group them into Multi-room Music groups.  When I go to play music it fails.  Is there a setting to allow Amazon Echo's to work together for multi-room music?

Meraki Employee

Hi @Basicme you should just be able to set up the speaker groups using the Amazon Alexa app, I have it running with no issues in my home.  Assuming you posted here because the devices are running on Meraki MR access point(s).  Take a look under Network-Wide > Clients and check their connectivity and addressing, etc. and see if they're on the same subnet/vlan for example.  Perhaps you have the SSID running in NAT mode which is typically the default, if so try running in Bridge Mode under Wireless > Configure > Access Control > Client IP assignment and see if that might help.  Let me know if I misunderstood the question.


@MerakiDave , thanks for the response.  I am using MR56 APs.  I have already switched to Bridge Mode and I have opened the UDP and TCP ports that Amazon support suggested.  Prior to those config settings I could not create a multi-room group.  Now I can create a group but when I ask Alexa (or in app) to play a song on a multi-room group it fails.


I also tried pushing all of them to 5GHz but that did not help.  I am currently using traffic steering to optimize 2.4/5



@Basicme just checking back on this, it sounds like you were able to create the multi-room group of Echo devices, but they will not all play music at the same time, it only comes through on a single device or maybe on none of them? 


You are running in Bridge Mode now for your SSID, and there is no L2 LAN isolation turned on right?  That setting is under the Wireless > Firewall and Traffic Shaping page.  So if you go to Network-Wide > Clients you are able to see each of the Echo devices in the clients list?  They all have an IP address on the same subnet/vlan?  And perhaps from some other device on your home network you can ping the IP address of each Echo device? 

Kind of a big deal
Kind of a big deal

@Basicme what switch are you using?  You might need to create an IGMP querier on the interface for the VLAN that the Echos are in.  It will get multicast working properly.

New here

This is also what is interesting and fascinating about music that we can find and use

Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.