AP and clients VLAN Setup

Macauley86
Here to help

AP and clients VLAN Setup

How can I configure my AP to get a DHCP address on VLAN 10 and have my SSID clients connect using VLAN 20?

 

I configured my switch port as a trunk port on VLAN 10. The AP receives an IP on that VLAN. I then configured my corporate SSID to use VLAN tag 20 for "all other APs." Yet, wifi clients receive IP addresses on VLAN 10 instead of VLAN 20.

 

What am I doing wrong?

5 REPLIES 5
RupertDot11
Meraki Employee

Your SSID configuration sounds right. 
Perhaps the trunk port to the AP is not allowing your SSID vlan?

The switch port the AP is connected to is a trunk port with native VLAN 10 and with all VLANs allowed, which includes VLAN 20. That's why I'm baffled that the clients connected to the corporate SSID are not receiving an IP in the correct VLAN. I'll check my configuration one more time just to make absolutely sure.

 

 

If you're using tags, ensure your tags have the correct VLAN assignment.

Bruce
Kind of a big deal

If the trunk to your AP is correct, and the SSID is in bridge mode tagging everything to VLAN 20, which it sounds like it all is, then the next area to check is your DHCP setup, and make sure you’ve not accidentally created a bridge between VLAN 10 and VLAN 20.

UCcert
Kind of a big deal

Hi @Macauley86 , as @RupertDot11 states, your switch uplink to the AP needs to be a Trunk. The Native VLAN needs to be the management VLAN that the AP needs to be on. Then ensure you allow any other relevant VLANs required for your SSIDs

Darren O'Connor | uccert.co.uk
https://www.linkedin.com/in/darrenoconnor/

I'm not an employee of Cisco/Meraki. My posts are based on Meraki best practice and what has worked for me in the field.
Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.