802.11r Roaming Issue

Getting noticed

802.11r Roaming Issue



Has anyone had any roaming issues with 802.11r where the device gets caught in an authentication/association loop?


I have it occurring specifically with Cisco 8821 wifi handsets.  They can roam between AP's most of the time without issue, but occasionally the 802.11r doesn't occur, and then the device just flips between 802.1X authentication and 802.11 association.


Device remains 'connected' but not authenticated and thus has no access.  This can go on for hours even when moving between AP's.  It seems the only way to kick it out of this behaviour is to turn the device off for 10 minutes so that there is complete disassociation and forcing it to do the full RADIUS auth.



Building a reputation



Which firmware are you running? If not already on MR 25.9, you should try upgrading to this. 





Running 25.9 on the AP's.  All the AP's are plugged into MS Switches running 9.34.


Happens across multiple sites.


iPhones are roaming trouble free.  Not saying it isn't the Cisco handsets, and they are known to have issues, just seeing if there are others having trouble as well.


Have had Meraki support look at it multiple times, and they blame the handset.  Haven't bothered with a Cisco TAC yet.

Building a reputation

What's the 802.11r  set to? Enabled or Adaptive? Have you tried switching between them to see if it fixes it?

It is set to Enabled.


Reluctant to change to Adaptive as if it doesn't think it is capable it will disable it.  We did test with 802.11r disabled, and it fixes the issue as there is full re-authentication on roam, however the delay it introduces in unacceptable.

Kind of a big deal

It will almost certainly be the firmware on the phones.  Is there any updates available?

Seems they are releasing new firmware every 2 months.  Is better than when they were first released a year ago, but still giving me far too much grief to roll this out to all our users.


I have opened a TAC case but not holding my breath for a quick fix.

Meraki Employee

Try downgrading to 24-12. I have a customer where this is happening and a downgrade to 24-12 fixed it for the time being. 

CCIEw# 45253 / CWNE# 249 / Senior Technical Marketing Engineer - Meraki MS Product
Get notified when there are additional replies to this discussion.
Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.