cancel
Showing results for 
Search instead for 
Did you mean: 

Most iOS apps vanished from Meraki Dashboard

Highlighted
Here to help

Most iOS apps vanished from Meraki Dashboard

As of when I configured the first of three new children's iPads sometime in the last couple of weeks, it installed new apps according to the applied profiles and, including Apple's preinstalled apps, ended up with over 300 apps installed. The remaining two children's iPads have 91 and 98 apps installed and none listed as missing. Identical profiles and policies on all three iPads. When the apps still hadn't installed after several days and weren't even showing up in the SM client on either iPad, I dug further and discovered that the Dashboard only listed 46 apps total and only 24 with the "kids" tag! Where did all of the others go? I tried re-importing all apps from VPP but ended up getting a message about trying to add apps with IDs that already existed. I still only have 46 apps total listed in Dashboard (Android AND iOS combined!) and no idea what happened to the rest. While I would greatly prefer to get them all back, tags included, I could live with re-importing if that would actually work. Unfortunately, it doesn't seem to. Running the free version of Systems Manager with 46 devices.

3 REPLIES
Here to help

Re: Most iOS apps vanished from Meraki Dashboard

Hmm. More details: The apps are there under VPP -> Apps but not under Configure -> Apps. Apps visible under VPP -> Apps show that licenses are in use but not where, since the licenses are device-assigned. Everything worked fine up until May 29, 2018. Issues appear to have started since then. The most recent activity shown under VPP -> Apps -> Recent Activity was on May 29, 2018.
Kind of a big deal

Re: Most iOS apps vanished from Meraki Dashboard

Maybe try going:

Systems Manager/Apps

Then in the top right "Accounts" and then "Refresh".

Here to help

Re: Most iOS apps vanished from Meraki Dashboard

Tried several times, including again this AM. No luck. Have a case open with Meraki through the dashboard but the last communique basically said to try what you suggested and to call in if that failed. Unfortunately, we're under the free-100 not an Enterprise license, so no calling in. Will have to poke support again via email or dashboard and get them to keep investigating. It's very strange since we have 460 apps under MDM -> VPP -> Licensed Applications and 46 under MDM -> Apps, so it's exactly 10% of the apps that are showing up.

I've tried going to MDM -> Apps and importing licensed iOS apps from the menu. If I select all apps and import, it *appears* to be successful - but when you look at the new apps in the list, they will show "Invalid Date" under "Last Modified" (and of course have lost all of their scope information) and if you click the "Save" button, nothing happens - it still shows unsaved changes. If you reload the page, it warns that you may lose unsaved changes and, if you sitll click "Reload", you do in fact lose changes and it goes back to only showing 46 apps.

If I try importing licensed iOS apps and only select 1 app that is currently not listed under MDM -> Apps, I can import it and save changes. The app will then have scope set to "disabled" and show the correct number of licenses available but no devices within the scope. If I set the scope to what it SHOULD be and save changes, it then shows the correct number of licenses available and also shows the current installation information - including devices which it was installed on before Meraki lost its marbles.

It is going to take days if I have to go through and re-import each app one by one and set the scope. I shouldn't need to do this. As far as I can tell after combing through the limited logs visible in the dashboard, nothing was done via the dashboard that should have caused this which means that it's a bug of some sort in Meraki. I want Meraki support to fix this.
Labels