cancel
Showing results for 
Search instead for 
Did you mean: 

Meraki Admin and the maps

Getting noticed

Meraki Admin and the maps

Recently we've noticed that within Meraki Admin, when you click on a device, it no longer zooms the Google map into the location of the device. It just "remembers" the last location you were looking at. So you have to zoom right out to find the bubble. Then instead of it zoom in to where the bubble is, it zooms into where you previously were, so you have to drag until you get to the bubble.

 

REALLY annoying. Have Google changed the way their maps API works and you haven't updated the code to reflect this so we're getting this odd behaviour? Or is something else broken?

 

And how long before a device switches to being traced via GPS? I've turned off WIFI on my mobile now, leaving only GPS on. Yet 20 mins later Meraki is still trying to trace me via IP.

28 REPLIES 28
DN
Here to help

Re: Meraki Admin and the maps

Good question Smiley Happy

Getting noticed

Re: Meraki Admin and the maps

It's been 36 mins since Meraki decided to check my phones location (via IP despite me having turned WIFI off). So 36mins since switching to GPS. Why does Meraki seem to take forever to refresh or switch over to other location search methods?

 

Map still not working properly with the automatic zoom when clicking the bubble.

 

And a correction. When zooming in, the map zooms into the centre. Still makes it infuriating to use the map now.

Head in the Cloud

Re: Meraki Admin and the maps

The map on Meraki for some reason has trouble either getting to the right spot or pinning the location at times. I keep wondering why that happens.

Building a reputation

Re: Meraki Admin and the maps

I have the same issue, not that I don't enjoy scrolling around the USA to find the machines but yet another feature that does not work.

 

 

Building a reputation

Re: Meraki Admin and the maps

yeah I've noticed i get more accurate results when my WiFi is on even if not connected
Highlighted
Getting noticed

Re: Meraki Admin and the maps

No one from Meraki at all? Is this forum community only? Been several days now with the WIFI off on my work phone yet Meraki still insists on searching for it via IP address so all known locations are wrong.

Getting noticed

Re: Meraki Admin and the maps

Another week almost gone, still nothing from Meraki. I've had more "prize" messages than answers.

Meraki Employee

Re: Meraki Admin and the maps

Hi @stevenwhiting @DN  @kYutobi  @Richard_W  @Cmiller 

 

  1. SM was experiencing an issue where device locations were being cached, resulting in the device map initially zooming in on previous device locations, or defaulting to a zoomed out map. We released an update yesterday which appears to have corrected this behavior.  Can you please confirm?
  2. Device location tracking via GPS has the following requirements:
    a) Location Service privileges are enabled for the SM app
    b) SM app is open and running in the background

    If both of these conditions are met, and you are continuing to have issues, please open a support case so that a representative can track this issue for you and supply the SM engineering team with the correct device/log information. 

 

A model citizen

Re: Meraki Admin and the maps

@Kevin_C I just checked mine as I have previously noticed this behavior and every iPad I checked, immediately zoomed in to the correct map location.

 

Please let the team know we appreciate the fix.

 

 

Found this helpful? Give me some Kudos! (click on the little up-arrow below)
Building a reputation

Re: Meraki Admin and the maps

Yes, now works for me too. I had to wait as all my remote teams were in town for the last couple of days.

Getting noticed

Re: Meraki Admin and the maps

Hi Kevin

 

Thanks for the reply. The maps are now working, the GPS location still isn't even though the SM app has the correct permissions on the phones and runs in the background.

 

We'll raise a ticket.

Building a reputation

Re: Meraki Admin and the maps

Anyone having issues with the maps just showing the world and not the device?

A model citizen

Re: Meraki Admin and the maps

@Richard_W I haven't seen any issues with devices and the maps today.

Found this helpful? Give me some Kudos! (click on the little up-arrow below)
Getting noticed

Re: Meraki Admin and the maps

I have these issues mostly when using Safari, on what browser are you?

A model citizen

Re: Meraki Admin and the maps

@beks88 I use Chrome for the most part. I don't recall seeing any issues with Safari on my MacBook.

Found this helpful? Give me some Kudos! (click on the little up-arrow below)
Building a reputation

Re: Meraki Admin and the maps

@beks88 Safari too.

 

this is what I'm getting:

 

Screen Shot 2019-07-15 at 9.23.27 AM.pngwhere in the world is Carmen's computer?

A model citizen

Re: Meraki Admin and the maps

I just fired up my MacBook running Mojave and I'm having no issues with maps and locations. 

 

What type of devices are these you are having issues with and are location services turned on for them?

Found this helpful? Give me some Kudos! (click on the little up-arrow below)
Building a reputation

Re: Meraki Admin and the maps

Nothing changed bar devices, all have locations services on prior.

 

Just a new oddity I was wondering if it is me alone, affected.

 

The location presented is correct but then the map zooms way out, by itself, manually zooming in: it is the approximate location but no marker on the map of the device. Weird.

 

Getting noticed

Re: Meraki Admin and the maps

This is my point of view Smiley Very Happy, latest Safari and Mojave. Doesn't matter what device. On Firefox fe I don't have this issue.

Bildschirmfoto 2019-07-15 um 21.48.48.png

 

A model citizen

Re: Meraki Admin and the maps

Well unless your devices are in a stationary orbit over the North Pole, yeah there's an issue.

Found this helpful? Give me some Kudos! (click on the little up-arrow below)
Building a reputation

Re: Meraki Admin and the maps

apparently my and @beks88 machines are in orbit…

Building a reputation

Re: Meraki Admin and the maps

Of course fine in Chrome, escalated to engineering…

Building a reputation

Re: Meraki Admin and the maps

@beks88 

 

According to engineering this is a client issue. I have stock Safari Version 12.1.1 (14607.2.6.1.1) running on macOS 10.14.5 (18F132) and have this issue. NO plug-ins.

 

Test on another Mac, similar specs and same issue.

 

What is your set up? And any resolution on your end?

A model citizen

Re: Meraki Admin and the maps

@Richard_W Fired up my MacBook and I have the same Safari and MacOS versions and my devices are now in a stationary orbit over the North Pole. 

 

If I use Chrome on the same MacBook the map displays locations correctly. 

Found this helpful? Give me some Kudos! (click on the little up-arrow below)
Building a reputation

Re: Meraki Admin and the maps

@vassallon Yes I too have no issues in Chrome, but Safari is my preferred browser. I'm struggling to see how this is a "client" issue and not a coding error from Meraki.

A model citizen

Re: Meraki Admin and the maps

@Richard_W Doing some digging with the Developer tools in Safari makes me agree with you.  

 

Screen Shot 2019-07-18 at 12.48.21 PM.pngConsole errors regarding Google Maps API

Found this helpful? Give me some Kudos! (click on the little up-arrow below)
Getting noticed

Re: Meraki Admin and the maps

OSX 10.4.5

Safari 12.1.1

 

We don't use the map as much, so we haven't opened a case. But will open a case and link to this thread so it hopefully gets resolved soon.

Building a reputation

Re: Meraki Admin and the maps

as per my case:

 

"I will try to recreate this in our lab environment. I will keep you up to date as soon as I get some more data."

 

Well at least it is now a thing.

Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.
Labels