Showing results for 
Search instead for 
Did you mean: 

Legacy Enrollment failing

Here to help

Legacy Enrollment failing

I am trying to enroll a Windows 10 Home machine in a Legacy Meraki account. Installing the agent appears to work as the service is running, but the machine never appears in the client list.


If I navigate to and enter the Network ID, it flashes up and says "Found: Company Name" but then comes up with a screen that says: -


You must install the Meraki Systems Manager desktop agent!


Anyone got any thoughts on why it can correctly find the network but then immediately tell me I need to install the Systems Manager Agent?


Note, I have disabled the firewall to ensure it is not blocking the agent.

Kind of a big deal

Re: Legacy Enrollment failing

Try downloading the agent manually from the Dashboard and then installing it.  I would also "right click/run as administrator" on it.

Here to help

Re: Legacy Enrollment failing

Thanks for the suggestions.

I have tried both of those although I don't get a "Run as Administrator" option when I right-click on the MSI that is downloaded.
Kind of a big deal

Re: Legacy Enrollment failing

Does Add/Remove programs show the agent as being installed?


Do you see the agent running in Task Manager?



I've never tried using it on a "Home" edition of windows.  I guess it is possible that something is missing from this edition that the Meraki agent needs.

Here to help

Re: Legacy Enrollment failing

Yes to both your questions.

It has been running on this machine previously. I noticed it wasn't working recently, so uninstalled and reinstalled the agent but to date, I have not been able to get it running properly again.

In addition, I have noticed that other clients (Windows and iOS) in the organisation are not updating the internal IP address correctly.

I am beginning to think it is a Legacy issue, but with no support from Cisco, I have no way of telling.
Here to help

Re: Legacy Enrollment failing

And to further support my suspicion that Cisco is starting to wind up the legacy product, if I try to Enroll the Device using the option available in Windows 10 Settings, I get a message that tells me "Enrollment Disabled", as shown in the screenshot below: -




Here to help

Re: Legacy Enrollment failing

This has been dormant for a while, but thought I would post the solution to my issue in case it helps anyone else.


Basically, there is a known incompatibility between AVG Anti-Virus and Meraki. AVG has no plans to change that. The following quote is from an Avast employee (they now own AVG): -


"It's not possible to whitelist such traffic at the moment so we don't recommend using AVG and "Meraki" together. Thank you for your understanding!"


You can read more here: -


I have confirmed this by uninstalling AVG from two VM's and Meraki then works perfectly. I note, it must be uninstalled, disabling it is not enough.

Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.
Points Contest
Join us for a month-long contest with heaps of swag to win!

Learn More ›