cancel
Showing results for 
Search instead for 
Did you mean: 

Could not retrieve license for the app

SOLVED
Conversationalist

Could not retrieve license for the app

Ok, so here is the situation.

 

I have replaced an ipod that had a defective battery with another one. I removed the old ipod from mdm as it went to the great apple store in the sky.

 

I go and try and add the licenses to the new ipod and it tells me the following "Error: Could not retrieve license for the app with iTunes Store ID", and on the device page i get " error: Could not retrieve license for the app with iTunes Store ID XXXX"

 

So ok, i go to the application, but under device licenses there is nothing. However it says 0/2 licenses available. As you can see, this is the second time this happened. Last time i just re bought the application to get around this, but this time I am going to get to the bottom of it.

 

I can see the serial numbers for the devices that the application is licensed to. Neither of the serial numbers are in meraki anymore (ipods are destroyed).

 

How do i revoke or reclaim these licenses? i checked on the apple VPP account and i cant see any way to do it from there. I have two different applications that have this problem currently, so its not an application problem. How do i reclaim a license when the device is long gone? i can see the old serial numbers as you can see below.

 

device licenses.pnglicenses missing.png

 

1 ACCEPTED SOLUTION

Accepted Solutions
Conversationalist

Re: Could not retrieve license for the app

It appears that i have fixed it.

 

What I did was "mark the application for deletion" in meraki. This removed it from meraki.

I then went onto the VPP section in meraki and did a sync.

Then, switching to the the "apps" section, i clicked Import -> Licensed ISO app. The application was displayed, still saying 0/2 licenses available.

After adding it, it still said 0/2 licenses available, but in the VPP section I could no longer bring up the list of installed serial numbers.

So just to try, I added the tag for the device i want it to install on. Waited a few minutes and refreshed the app page. It now says 1/2 licenses available and has applied the license to the correct device now!

 

so basically, delete application from meraki, re sync to VPP and re import. Then re add to the device and for some reason this caused everything to fall back into sync.

 

Thanks all for your good advice. Hopefully this helps someone else going forward. Up until the very last step, where i re-assigned the application to the device, it was still saying the wrong license count.

5 REPLIES
Kind of a big deal

Re: Could not retrieve license for the app

I think this is an Apple restriction - you bought the licences and assigned them to an device.  I don't think Apple lets you transfer them in that way.

Kind of a big deal

Re: Could not retrieve license for the app

@licenseNOW

 

When a license is assigned to a device, it is revocable. Navigate to Systems Manager > VPP (under "Manage" Heading) and check the app you are having problems with then click "Edit Auto Management" and check the following options. Finally, click Apply changes and your license count should update. I prefer to apply these options to all app I place in Self Service for users.Screen Shot 2018-12-05 at 11.04.52 PM.png

Find this helpful? Click the kudos button. Thanks!
Highlighted
Conversationalist

Re: Could not retrieve license for the app

mr jared, you are quite right that needs to be set. that is why we always set it.

 

i dont set "auto grant users in scope" because i dont think that has anything to do with device licenses. And we do have some "user" licenses and i dont want to auto grant it to those nessecarily. but its set as you said and still does not revoke it.

auto revoke.png

 

and on the application itself.

 

mdm options.png

 

But yes i fully hope that it is a problem with my configuration and not a limitation on apple. I grant and revoke licenses all the time successfully. The only difference here is the devices that i want to revoke from are not longer active (destroyed, rma'ed, whatever you want to call it). I really hope the licenses dont go with them. I mean what if they were stolen? there has to be a way to revoke. i can see the old serial numbers even! so the system is aware of the devices where it is licensed to. i just need to figure out how to unlicense from those SN.

Building a reputation

Re: Could not retrieve license for the app

So I had this happen over the summer as we did a full iPad refresh. We had several paid for apps that did not release licenses correctly when the old iPads were dropped from DEP and Meraki. No matter how many times I forced a VPP sync between Meraki and Apple it would not drop the licenses from the old iPads.

 

In order to fix this a "reset" our licenses, Meraki support advised adding the apps we were having issues with to another network. I used the Apple Device Enrollment Program network, as that is our default dumping ground for new devices before they are moved into an individual location. I imported all of our apps and set them to auto-install and device based pushes. This did the trick and reset the licenses but doesn't explain why when a device is dropped from DEP and Meraki the license didn't auto-release.

Found this helpful? Give me some Kudos! (click on the little up-arrow below)
Conversationalist

Re: Could not retrieve license for the app

It appears that i have fixed it.

 

What I did was "mark the application for deletion" in meraki. This removed it from meraki.

I then went onto the VPP section in meraki and did a sync.

Then, switching to the the "apps" section, i clicked Import -> Licensed ISO app. The application was displayed, still saying 0/2 licenses available.

After adding it, it still said 0/2 licenses available, but in the VPP section I could no longer bring up the list of installed serial numbers.

So just to try, I added the tag for the device i want it to install on. Waited a few minutes and refreshed the app page. It now says 1/2 licenses available and has applied the license to the correct device now!

 

so basically, delete application from meraki, re sync to VPP and re import. Then re add to the device and for some reason this caused everything to fall back into sync.

 

Thanks all for your good advice. Hopefully this helps someone else going forward. Up until the very last step, where i re-assigned the application to the device, it was still saying the wrong license count.

Labels