Showing results for 
Show  only  | Search instead for 
Did you mean: 

Can't uninstall custom app on Android


Can't uninstall custom app on Android

Testing on my Nexus 5X Android 8.1.0, deploy SM with a custom app, added the "allow unknown app to install" to the profile and the app installs fine.

When I go to uninstall the app however I just keep getting the error

"error: Cannot remove app; not managed on this device"


The app is remotely installed when I deploy so it should be managed. It has the manage image on top of the icon on the phone, however I notice sometimes when I open SM it shows the app with the Install button, and sometimes with the Manage button, even though the app is installed from the start.


Is there another policy setting I'm missing or something with how I added the custom app to MDM?


Re: Can't uninstall custom app on Android

Is the app still listed on the apps page in the system manager? Anyway few weeks ago I deleted an app in that app list but the device was still logging the app as installed. Also received the error that the app wasn't managed. 

If the app isn't in the list anymore, try to add it again, and afterwards try to sync with your phone.

If the app is listed as installed, try to uninstall it again. 

That helped for me.


Re: Can't uninstall custom app on Android

Thanks for the reply Niels, I tried re adding the App to Meraki with a different Name as I had removed and re-added a few to test with the same name. Still the same result. I can open the SM on the phone, click on managed apps, it's sitting there with the option to remove, but try doing that via MDM and it gives an error every time.

Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.