cancel
Showing results for 
Search instead for 
Did you mean: 

Apple DEP and SM Devices SN Disagreement

Conversationalist

Apple DEP and SM Devices SN Disagreement

Folks,

 

New to SM & DEP.  Working toward a proper MDM setup that allows us greater control over company assets, and have so far worked with our mobile carrier to have our purchased Apple devices added to our Apple Business portal and get the MDM server added.  Through this process I added the MDM server, generated the token (on Apple's Business Portal) and added that into my Meraki Dashboard.  Everything tests okay and seems to be working according the documentation I found; outdated docs notwithstanding.

 

The carrier (Verizon in our case) has injected those devices into our Apple DEP and they now show in the Meraki Dashboard within SM > DEP thusly:

DEP1.png

 

 

The trouble I'm having is that none of the SN seem to match devices I have in-hand.  I had manually added a few devices while I waited for Verizon and Apple to work out the DEP and shovel the devices into the proper location--those devices seem to add in properly using SM > Add Devices > iOS.  I can see their information, although they are not supervised (which I suspect is because they were not added via DEP).

 

Searching SM > DEP with a known SN of one of the devices listed here below, I get no result.  So I'm unable to match a device that I know was purchased through Verizon, and was allegedly added into DEP via Verizon to Apple and sync'd with my Meraki Dashboard.  

DEP2.png

Have I missed a step along the way?  I'm looking for any guidance or experience from the folks here who have worked with this product before, as I can't seem to make sense of it.  I can't figure out why my devices that were added to DEP by Apple (via Verizon) don't seem to match the actual devices on-hand, so I don't dare move forward rolling out any type of management on the devices I do have listed within DEP.

 

Cheers,

John

6 REPLIES 6
A model citizen

Re: Apple DEP and SM Devices SN Disagreement

Have the enrolled devices been turned on and set up? When a device is assigned to your Meraki EMM server it will show up in the DEP list under SM > Mange > DEP (this will also display the network they are assigned to), Once the device has been turned on and set up (gotten to the home screen) it will then show up in the network you assigned it to and when viewing it in the DEP list will then say the enrollment is pushed as apposed to assigned (Screenshot below).

 

Screen Shot 2018-11-13 at 12.33.22 PM.png

Conversationalist

Re: Apple DEP and SM Devices SN Disagreement

The devices have all been in deployment prior to the roll out of DEP--so to answer your question: yes they are turned on and set up.  But seeing as how they were already deployed, and Verizon recently pushed the request to Apple Business Manager I am assuming that is impacting device visibility in my Meraki Dashboard.  

 

The real issue I'm having is that Serial Numbers for known devices (the few iPhones and iPads I have manually added to SM) do not match any of the SN's shown in SM > DEP.  Very odd, but I'm sure it's a configuration issue I just don't know how to correct due to lack of experience with it.

 

Within SM > DEP if I take a SN from a device that I have in-hand (and have added manually to SM) the DEP page tells me it doesn't exist:

DEP3.png

A model citizen

Re: Apple DEP and SM Devices SN Disagreement

As for the devices that were deployed prior them added to DEP. Those will need to be wiped and re-setup. It's during the activation of the setup process that they enroll themselves in DEP. You can still add them to the Meraki MDM and manage them, but to supervise them and use DEP they will need to be wiped.

 

For the SN's not matching up with what you are seeing under SM > DEP. Is it possible that some of your SNs that you set up previously just were not added by Verizon to your DEP account? Are you able to get a report from Verizon of the SN's they enrolled into Apple Business Manger for you and a report of devices they sent you and compare those to make sure they did not mix something up?

Conversationalist

Re: Apple DEP and SM Devices SN Disagreement

So the existing devices will not enroll under DEP without being wiped.  That makes sense, I'll probably have a hard time tracking them all down for that project but it's something to put on the board.  Thanks for the advice, I appreciate it.

 

I couldn't say for sure what was or was not added via Verizon.  I did email our Verizon rep who worked with me on this project to see if he could make sense of what is going on with the mismatching SN's.  I don't believe it's possible that the devices I already setup were not added, as every device from our account was allegedly added into DEP.  The numbers match up (in terms of how many devices my Verizon account says we have--and how many were added into DEP).  It's just that the actual device SN don't seem to match what was added...which seems very strange to me.  I'll have to post back what I hear from Verizon on this front, I suppose.

 

Cheers

A model citizen

Re: Apple DEP and SM Devices SN Disagreement

Glad I can help out. For sure let us know what you find out from your Verizon rep.

Conversationalist

Re: Apple DEP and SM Devices SN Disagreement

Spoke to Verizon.  Was informed that it must be something wrong on Apple's end.  Got on support with Apple, and transferred to a Senior Rep who worked with me and determined that Verizon must have imported the wrong orders to my account to have this issue occur (and informed me that it isn't the first time they've seen it).

 

Got back in touch with Verizon, and as of this post they are still trying to figure it out.  Certainly chewing up the days on my SM trial license...

Welcome to the Meraki Community!
To start contributing, simply sign in with your Cisco account. If you don't yet have a Cisco account, you can sign up.
Labels