Erroneous VLAN Mismatch Alerts on LACP trunk

jefanell
Here to help

Erroneous VLAN Mismatch Alerts on LACP trunk

I'm seeing erroneous VLAN mismatch alerts on both 9k switch ports in my LACP link to another (monitored) 9k.

 

Neither switch is showing any errors etc, and the LACP port channel is happy.

Screenshot 2023-01-23 at 10.45.54 PM.png

Screenshot 2023-01-23 at 10.46.07 PM.png

 

relevant config on switch 1:

 

interface Port-channel12

switchport mode trunk

device-tracking attach-policy MERAKI_POLICY

no logging event link-status

snmp trap mac-notification change added

snmp trap mac-notification change removed

!

interface TenGigabitEthernet1/0/43

description 9300-macavia-lacp

switchport mode trunk

logging event trunk-status

logging event spanning-tree

logging event status

snmp trap mac-notification change added

snmp trap mac-notification change removed

channel-protocol lacp

channel-group 12 mode active

spanning-tree portfast

ip nbar protocol-discovery

!

interface TenGigabitEthernet1/0/44

description 9300-macavia-lacp

switchport mode trunk

logging event trunk-status

logging event spanning-tree

logging event status

snmp trap mac-notification change added

snmp trap mac-notification change removed

auto qos trust

channel-protocol lacp

channel-group 12 mode active

spanning-tree portfast

service-policy input AutoQos-4.0-Trust-Cos-Input-Policy

service-policy output AutoQos-4.0-Output-Policy

ip nbar protocol-discovery

 

relevant config on switch 2:

 

interface Port-channel1

no logging event link-status

ip dhcp snooping trust

!

interface TenGigabitEthernet1/1/1

description 9300-core-uplink

logging event trunk-status

logging event spanning-tree

logging event status

snmp trap mac-notification change added

snmp trap mac-notification change removed

channel-protocol lacp

channel-group 1 mode active

ip dhcp snooping trust

!

interface TenGigabitEthernet1/1/2

description 9300-core-uplink

logging event trunk-status

logging event spanning-tree

logging event status

snmp trap mac-notification change added

snmp trap mac-notification change removed

channel-protocol lacp

channel-group 1 mode active

ip dhcp snooping trust

4 REPLIES 4
alemabrahao
Kind of a big deal

You have not configured the switch on trunk mode.

 

alemabrahao_0-1674557374387.png

 

alemabrahao_1-1674557397970.png

 

 

For link between switches you have to use spanning tree link type point to point.

GIdenJoe
Kind of a big deal

Also don't configure portfast on ports going to other switches.  It defeats the purpose.

Make sure both switches have the same VLAN's configured.

 

And please provide an output for show interfaces trunk.

DevOps_RC
Getting noticed

I have a similar issue, except it is between C9300 & MS390 stacks. The allowed trunk ports match but the one that doesn't is the native vlan, but I haven't changed the value yet as they are working as intended and they are a critical piece of our infrastructure and I've yet to pluck up the courage to make a change. If you view the ports in the meraki dahsboard, what does it show under the vlan mismatch info when you click on Warning: Vlan Mismatch under the CDP/LLDP value in the status section? Image is taken from my dashboard, but I can't show the info under the warning pop-up

DevOps_RC_0-1675158809178.png

 

Get notified when there are additional replies to this discussion.